Visual Matrix is not Launching on the Client Computer (Desktop)

Visual Matrix is not Launching on the Client Computer (Desktop)


As a VM Desktop PMS user with multiple machines, your system operates with a server and client computers. The client computer only has the Visual Matrix application installed. For the application to function (launch and log in), it requires access to a database stored solely on the server machine. If the communication between the server and client machines is disrupted, Visual Matrix will not launch on the client machine. Troubleshooting the issue and identifying the error can be a lengthy process, but it is certainly manageable. This article provides a step-by-step guide to help you through it.


1. Get connected to the Client Station AND the Main Server

2. Check the error on the Client Station
- Launch Visual Matrix to double-check the error code.
- Answer this question: Do you have other Client Stations? Is it happening on all Clients or just one?

3. Make sure UAC is disabled

4. Make sure the Client Station and the Main Server are both on the Ethernet internet connection

5. Make sure the Network is Private (vs Public).
- Do a left-click on the Ethernet icon in the taskbar (see the article in the previous step above).
- Click on the Network name. It will open the Ethernet Settings.
- Click again on the Network name in the Settings window.
- In the details window, make sure the connection is Private and not Public.
- If Public, change it to Private.

6. Check the Server Name and IP

7. Check the Registry on any Station Visual Matrix is not opening.

Alert
If you cannot browse in one or the other way, please check with your IT support.
NotesTry to launch Visual Matrix. If it still fails, continue troubleshooting.

NotesTry to launch Visual Matrix. If it still fails, continue troubleshooting.

Check Antivirus/Malware Permissions. Make sure the third-party firewall/malware/antivirus is permissioned to let any files from the ImageTech folder to work.
You can try to give Port 1702 permission in the Firewall settings of their Antivirus. Visual Matrix runs through this port.
The process will depend on which Antivirus/Firewall you have installed. As we cannot give all the processes for every existing antivirus/firewall application, Google Search is generally a good place to start to find how.

11. See if the Client PC can telnet to port 1702 on the server's local IP (aka IPv4) - all clients should be able to telnet to the server IP into port 1702
If you are a BW, contact GLS/MSS department to unblock the port.

Notes
Try to launch Visual Matrix. If it still fails, reactivate the Firewall and contact a Visual Matrix Client Experience Team.
Idea
The best way to prevent this issue in the future is to upgrade to VM Cloud PMS. If you haven't made the switch yet, consider it and reach out to our Sales team for more information!